package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\d\s*){5}\d`)
var str = `1 23456
1 2 3456
1 2 3 456
1 2 3 4 56
1 2 3 4 5 6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}