$re = '/(?:\d\s*){5}\d/';
$str = '1 23456
1 2 3456
1 2 3 456
1 2 3 4 56
1 2 3 4 5 6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);