import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{8,12}$)(?=[^A-Z]*[A-Z])(?=\\D*\\d)(?=(?:[^a-z]*[a-z]){3})(?=[^\\s#*.!?$]*[#*.!?$])(?!.*(.)\\1)(?:[a-z]|[A-Z])[a-zA-Z0-9#*.!?$,]+$";
final String string = "Abcd123!,\n"
+ "Abcd123!,\n"
+ "abcD123!,dfe\n\n"
+ "abcD123,dfe\n"
+ "abcD122!,dfe";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}