const regex = /^(?=.{8,12}$)(?=[^A-Z]*[A-Z])(?=\D*\d)(?=(?:[^a-z]*[a-z]){3})(?=[^\s#*.!?$]*[#*.!?$])(?!.*(.)\1)(?:[a-z]|[A-Z])[a-zA-Z0-9#*.!?$,]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{8,12}$)(?=[^A-Z]*[A-Z])(?=\\D*\\d)(?=(?:[^a-z]*[a-z]){3})(?=[^\\s#*.!?$]*[#*.!?$])(?!.*(.)\\1)(?:[a-z]|[A-Z])[a-zA-Z0-9#*.!?$,]+$', 'gm')
const str = `Abcd123!,
Abcd123!,
abcD123!,dfe
abcD123,dfe
abcD122!,dfe`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}