re = /^(?=.{8,12}$)(?=[^A-Z]*[A-Z])(?=\D*\d)(?=(?:[^a-z]*[a-z]){3})(?=[^\s#*.!?$]*[#*.!?$])(?!.*(.)\1)(?:[a-z]|[A-Z])[a-zA-Z0-9#*.!?$,]+$/m
str = 'Abcd123!,
Abcd123!,
abcD123!,dfe
abcD123,dfe
abcD122!,dfe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end