import re
regex = re.compile(r"\s{10}Глава ", flags=re.MULTILINE)
test_str = ("<?php\n"
"$blocks = [\n"
" 'ревочной лестницы — небось скрючило бы в три погибели! Не скоро запросил бы еды, я — то уж знаю!\n"
" \n\n"
" Нат не стал смотреть, как мы клали заколдованный пирог Джиму в миску, а в самый низ, под провизию, мы сунули три жестяные тарелки, и Джим все это получил в полном порядке; а как только остался один, разломал пирог и спрятал веревочную лестницу к себе в тюфяк, а потом нацарапал какие-то каракули на тарелке и выбросил ее в окно.\n"
" \n\n"
" \n\n"
" \n\n"
" Глава тридцать восьмая\n"
" “ЗДЕСЬ РАЗОРВАЛОСЬ СЕРДЦЕ УЗНИКА”\n"
" \n\n"
" Делать эти самые перья было сущее мученье',\n"
" 'ете, голубчик? Испеките, да я вам за это что угодно — в ножки поклонюсь, вот как!\n"
" — Ладно уж, испеку, раз это для тебя: ты ведь к нам хорошо относился, беглого негра нам показал. Только уж смотри будь поосторожней. Когда мы придем, ты повернись к нам спиной, и боже тебя упаси глядеть, что мы будем класть в миску! И когда Джим будет вынимать пирог, тоже не гляди — мало ли что может случиться, я почем знаю! А главное, не трогай ничего заколдованного.\n"
" — Не трогать? Да господь с вами, мистер Сид! Я и пальцем ни до чего не дотронусь, хоть озолоти меня!\n"
" \n"
" \n"
" Глава тридцать седьмая\n"
" ДЖИМ ПОЛУЧАЕТ ВОЛШЕБНЫЙ ПИРОГ\n"
" \n\n"
" Это дело мы уладили; потом пошли на задний двор, к мусорной куче, где валялись старые сапоги, тряпки, битые бутылки, дырявые кастрюльки и прочий хлам, покопались в нем и разыскали старый жестяной таз, заткнули получше дырки, чтобы испечь в нем пирог, спустились в погреб и насыпали полный таз муки, а оттуда пошли завтракать. По дороге нам попалось два обойных гвоздя, и Том сказал, что они пригодятся узнику — выцарапать ими на стене темницы свое имя и свои злоключения; один гвоздь мы'\n"
" ];")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")