import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ip dhcp excluded-address ([\\d\\.]*)($| ([\\d\\.]*)$)";
final String string = "ip dhcp excluded-address 10.10.8.1 10.10.8.100\n"
+ "ip dhcp excluded-address 10.8.8.1 10.8.9.0\n"
+ "ip dhcp excluded-address 192.168.0.1 192.168.0.10\n"
+ "ip dhcp excluded-address 10.10.9.12\n"
+ "ip dhcp excluded-address 10.10.9.14\n"
+ "!\n"
+ "ip dhcp pool Pool1\n"
+ " network 10.10.8.0 255.255.248.0\n"
+ " update dns both override\n"
+ " dns-server 10.10.1.10 10.10.1.11 \n"
+ " default-router 10.10.8.1 \n"
+ " lease 8\n"
+ "!\n"
+ "ip dhcp pool Pool2\n"
+ " network 10.8.8.0 255.255.248.0\n"
+ " update dns both override\n"
+ " default-router 10.8.8.1 \n"
+ " dns-server 10.10.1.10 10.10.1.11 \n"
+ " lease 8\n"
+ "!\n"
+ "ip dhcp pool Pool3\n"
+ " network 192.168.0.0 255.255.255.0\n"
+ " update dns both override\n"
+ " dns-server 10.10.1.10 10.10.1.11 \n"
+ " default-router 192.168.0.1 \n"
+ " lease 8\n"
+ "!\n"
+ "ip dhcp pool Device1\n"
+ " host 10.10.10.84 255.255.248.0\n"
+ " client-identifier 0100.24ee.065d.3e\n"
+ "!\n"
+ "ip dhcp pool Device2\n"
+ " host 10.10.10.115 255.255.248.0\n"
+ " client-identifier 0194.c691.6a43.3f\n"
+ "!\n"
+ "ip dhcp pool Device3\n"
+ " host 10.10.10.250 255.255.248.0\n"
+ " client-identifier 0194.c691.fb53.7e\n"
+ "!\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}