# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"ip dhcp excluded-address ([\d\.]*)($| ([\d\.]*)$)"
test_str = ("ip dhcp excluded-address 10.10.8.1 10.10.8.100\n"
"ip dhcp excluded-address 10.8.8.1 10.8.9.0\n"
"ip dhcp excluded-address 192.168.0.1 192.168.0.10\n"
"ip dhcp excluded-address 10.10.9.12\n"
"ip dhcp excluded-address 10.10.9.14\n"
"!\n"
"ip dhcp pool Pool1\n"
" network 10.10.8.0 255.255.248.0\n"
" update dns both override\n"
" dns-server 10.10.1.10 10.10.1.11 \n"
" default-router 10.10.8.1 \n"
" lease 8\n"
"!\n"
"ip dhcp pool Pool2\n"
" network 10.8.8.0 255.255.248.0\n"
" update dns both override\n"
" default-router 10.8.8.1 \n"
" dns-server 10.10.1.10 10.10.1.11 \n"
" lease 8\n"
"!\n"
"ip dhcp pool Pool3\n"
" network 192.168.0.0 255.255.255.0\n"
" update dns both override\n"
" dns-server 10.10.1.10 10.10.1.11 \n"
" default-router 192.168.0.1 \n"
" lease 8\n"
"!\n"
"ip dhcp pool Device1\n"
" host 10.10.10.84 255.255.248.0\n"
" client-identifier 0100.24ee.065d.3e\n"
"!\n"
"ip dhcp pool Device2\n"
" host 10.10.10.115 255.255.248.0\n"
" client-identifier 0194.c691.6a43.3f\n"
"!\n"
"ip dhcp pool Device3\n"
" host 10.10.10.250 255.255.248.0\n"
" client-identifier 0194.c691.fb53.7e\n"
"!\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.