package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<serialCode>[a-zA-Z0-9]{3})(?:(?<serialMarket>[a-zA-Z]{1,2})(?<serialSuffix>[a-zA-Z0-9]*))?`)
var str = `abcfobar
abc33bar
abca3bar
abc3abar
ab3abar
c3abar
3abar
bar
ab3a3ar
c3ab4r
3aba4
bar
234f22fsdf
a23a3ar
c3ab4r
3aba4
bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}