import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<serialCode>[a-zA-Z0-9]{3})(?:(?<serialMarket>[a-zA-Z]{1,2})(?<serialSuffix>[a-zA-Z0-9]*))?";
final String string = "abcfobar\n"
+ "abc33bar\n"
+ "abca3bar\n"
+ "abc3abar\n\n"
+ "ab3abar\n"
+ "c3abar\n"
+ "3abar\n"
+ "bar\n\n"
+ "ab3a3ar\n"
+ "c3ab4r\n"
+ "3aba4\n"
+ "bar\n\n"
+ "234f22fsdf\n\n\n"
+ "a23a3ar\n"
+ "c3ab4r\n"
+ "3aba4\n"
+ "bar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}