using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<p>)(.[^<\/p>]*)(<\/p>)";
string input = @"<table><tr><td> <p>Text 1</p></td> </tr> <tr><td> <p>Text 2</p></td> </tr> <tr><td> <p>Text 3</p></td> </tr> </tr> </table>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}