const regex = /(<p>)(.[^<\/p>]*)(<\/p>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<p>)(.[^<\\\/p>]*)(<\\\/p>)', 'gm')
const str = `<table><tr><td> <p>Text 1</p></td> </tr> <tr><td> <p>Text 2</p></td> </tr> <tr><td> <p>Text 3</p></td> </tr> </tr> </table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}