#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d[\s-])(?<!\d)4\d{3}(?![\s-]?\d)"
Local $sString = "For example: 4567 (match)" & @CRLF & _
"" & @CRLF & _
"I have 4999 roses (match)" & @CRLF & _
"" & @CRLF & _
"1234567 days are gone (no match)" & @CRLF & _
"" & @CRLF & _
"My water supply account is 123 4567 89 (no match)" & @CRLF & _
"" & @CRLF & _
"Howdy, my cell number is 123-4567-89 (no match)" & @CRLF & _
"" & @CRLF & _
"no match for 123 4567"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")