$re = '/(?<!\d[\s-])(?<!\d)4\d{3}(?![\s-]?\d)/m';
$str = 'For example: 4567 (match)
I have 4999 roses (match)
1234567 days are gone (no match)
My water supply account is 123 4567 89 (no match)
Howdy, my cell number is 123-4567-89 (no match)
no match for 123 4567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);