const regex = /(?<!\d[\s-])(?<!\d)4\d{3}(?![\s-]?\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d[\\s-])(?<!\\d)4\\d{3}(?![\\s-]?\\d)', 'gm')
const str = `For example: 4567 (match)
I have 4999 roses (match)
1234567 days are gone (no match)
My water supply account is 123 4567 89 (no match)
Howdy, my cell number is 123-4567-89 (no match)
no match for 123 4567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}