#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?![azAZ]).)*$"
Local $sString = "123456789" & @CRLF & _
"abc123456" & @CRLF & _
"981984623" & @CRLF & _
"98198abc1" & @CRLF & _
"197197114" & @CRLF & _
"ab7189747" & @CRLF & _
"12345678a" & @CRLF & _
"A12X48967"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")