const regex = /^((?![azAZ]).)*$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?![azAZ]).)*$', 'mg')
const str = `123456789
abc123456
981984623
98198abc1
197197114
ab7189747
12345678a
A12X48967`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}