re = /^((?![azAZ]).)*$/m
str = '123456789
abc123456
981984623
98198abc1
197197114
ab7189747
12345678a
A12X48967'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end