const regex = /.*(?=\bhi\b).*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(?=\\bhi\\b).*', 'gmi')
const str = `there is difference between this string and that string
hi there, is difference between that string and other string false?
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}