re = /.*(?=\bhi\b).*/mi
str = 'there is difference between this string and that string
hi there, is difference between that string and other string false?
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end