$re = '/.*(?=\bhi\b).*/mi';
$str = 'there is difference between this string and that string
hi there, is difference between that string and other string false?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);