#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]{4,5}(;[0-9]{4,5})?$"
Local $sString = "1111" & @CRLF & _
"11111" & @CRLF & _
"1111;1111" & @CRLF & _
"11111;1111" & @CRLF & _
"11111;11111" & @CRLF & _
"111" & @CRLF & _
"111;" & @CRLF & _
"1111;1" & @CRLF & _
"11111;1" & @CRLF & _
"abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")