package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{4,5}(;[0-9]{4,5})?$`)
var str = `1111
11111
1111;1111
11111;1111
11111;11111
111
111;
1111;1
11111;1
abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}