$re = '/^[0-9]{4,5}(;[0-9]{4,5})?$/m';
$str = '1111
11111
1111;1111
11111;1111
11111;11111
111
111;
1111;1
11111;1
abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);