import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "id_image\":\\[\\{\"url\":\"(.*?)\"";
final String string = "tutaj jakas tresc id_image\":[{\"url\":\"https://przyklad.pl/dalej/ef5d61cbd1f310f094ffc9bb9913acb3-24.jpg\" cos wiecej";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}