$re = '/id_image":\[{"url":"(.*?)"/';
$str = 'tutaj jakas tresc id_image":[{"url":"https://przyklad.pl/dalej/ef5d61cbd1f310f094ffc9bb9913acb3-24.jpg" cos wiecej';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);