const regex = /id_image":\[{"url":"(.*?)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('id_image":\\[{"url":"(.*?)"', 'g')
const str = `tutaj jakas tresc id_image":[{"url":"https://przyklad.pl/dalej/ef5d61cbd1f310f094ffc9bb9913acb3-24.jpg" cos wiecej`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}