package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:([+-]?\d*)x\^[0-9])?(?:([+-]?\d+)x)?([+-]?\d+)?$`)
var str = `-2x^2+7x-1
-x^2+7x-1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}