re = /^(?:([+-]?\d*)x\^[0-9])?(?:([+-]?\d+)x)?([+-]?\d+)?$/m
str = '-2x^2+7x-1
-x^2+7x-1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end