// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:([+-]?\d*)x\^[0-9])?(?:([+-]?\d+)x)?([+-]?\d+)?$").unwrap();
let string = "-2x^2+7x-1
-x^2+7x-1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}