package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]+(?:,%20[0-9]+)*`)
var str = `961540,%20961557,%20961565,%20961573,%20961581,%20961599`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}