re = /[0-9]+(?:,%20[0-9]+)*/m
str = '961540,%20961557,%20961565,%20961573,%20961581,%20961599'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end