import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http(?:s)?:\\/\\/)((?:(?:\\w+)\\.?)+\\/)(vtvnpvr\\S{0,10}\\/sdash\\/)(.*)(CUP|TDT)(\\S{1,3})(\\/\\S{4,100})((\\?)|(&)device)=(\\S{1,5})_(\\S{1,5})_(\\S{1,100})";
final String string = "http://vfccastcdn.gb.vodafone.es/vtvnpvr2/sdash/LIVE%24TDT001/2.mpd/Manifest?start=2018-11-20T16:55:00Z&end=2018-11-20T19:30:00Z&device=DASH_VTV_ENC_NPVR\n\n"
+ "http://vfccastcdn.gb.vodafone.es/vtvnpvr/shss/LIVE%24CUP156/2.ism/Manifest?start=2018-11-20T16:55:00Z&end=2018-11-20T19:30:00Z&device=HSS_OTT_ENC_NPVR\n\n\n"
+ "http://vfvtvcdn.gb.vodafone.es/shss/LIVE$CUP156/2.ism/Manifest?start=2018-02-20T16:00:00Z&end=2018-02-20T17:00:00Z&device=HSS_VTV_AVC_ENC_RB_HD\n\n";
final String subst = "$1vfott2cdn.gb.vodafone.es/$3$4CUP$6$7$8=$11_XDSL_$13";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}