re = /(http(?:s)?:\/\/)((?:(?:\w+)\.?)+\/)(vtvnpvr\S{0,10}\/sdash\/)(.*)(CUP|TDT)(\S{1,3})(\/\S{4,100})((\?)|(&)device)=(\S{1,5})_(\S{1,5})_(\S{1,100})/
str = 'http://vfccastcdn.gb.vodafone.es/vtvnpvr2/sdash/LIVE%24TDT001/2.mpd/Manifest?start=2018-11-20T16:55:00Z&end=2018-11-20T19:30:00Z&device=DASH_VTV_ENC_NPVR
http://vfccastcdn.gb.vodafone.es/vtvnpvr/shss/LIVE%24CUP156/2.ism/Manifest?start=2018-11-20T16:55:00Z&end=2018-11-20T19:30:00Z&device=HSS_OTT_ENC_NPVR
http://vfvtvcdn.gb.vodafone.es/shss/LIVE$CUP156/2.ism/Manifest?start=2018-02-20T16:00:00Z&end=2018-02-20T17:00:00Z&device=HSS_VTV_AVC_ENC_RB_HD
'
subst = '$1vfott2cdn.gb.vodafone.es/$3$4CUP$6$7$8=$11_XDSL_$13'
result = str.sub(re, subst)
# Print the result of the substitution
puts result