re = /(?i)(.*ZebraDesigner.exe.*)/m
str = 'HwndWrapper|ZebraDesigner.exe::c4040ea4-
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end