package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)(.*?)someword`)
var str = `43434 of someword 877 someword 123 someword 12 anything someword 2323 someword`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}