re = /(\d+)(.*?)someword/m
str = '43434 of someword 877 someword 123 someword 12 anything someword 2323 someword'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end