$re = '/(\d+)(.*?)someword/m';
$str = '43434 of someword 877 someword 123 someword 12 anything someword 2323 someword';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);