package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(CVE-(?<CVE>[^\)]*)\)`)
var str = `XXXXDxxxre xxxrability (CVE-201x-00xx) (severity = Low)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}