re = /\(CVE-(?<CVE>[^\)]*)\)/
str = 'XXXXDxxxre xxxrability (CVE-201x-00xx) (severity = Low)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end