package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)PulseSecure: (?<Extracted>.*)`)
var str = `Dec 27 06:29:37 AAAAAA PulseSecure: 2021-12-27 06:29:37 - AAAAAA - [110.1.1.1] Default Network::aa.aa.aa(AAA_BBB)[BB_CC_EEE]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}