import re
regex = re.compile(r"PulseSecure: (?<Extracted>.*)", flags=re.MULTILINE)
test_str = "Dec 27 06:29:37 AAAAAA PulseSecure: 2021-12-27 06:29:37 - AAAAAA - [110.1.1.1] Default Network::aa.aa.aa(AAA_BBB)[BB_CC_EEE]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")