re = /PulseSecure: (?<Extracted>.*)/m
str = 'Dec 27 06:29:37 AAAAAA PulseSecure: 2021-12-27 06:29:37 - AAAAAA - [110.1.1.1] Default Network::aa.aa.aa(AAA_BBB)[BB_CC_EEE]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end