using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:ssh|https):\/\/(?:git@)?bitbucket\.org\/([^/]*)\/([^/.]*)";
string input = @"https://bitbucket.org/test/test-x.git
ssh://git@bitbucket.org/test/test-x";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}