package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:ssh|https):\/\/(?:git@)?bitbucket\.org\/([^/]*)\/([^/.]*)`)
var str = `https://bitbucket.org/test/test-x.git
ssh://git@bitbucket.org/test/test-x`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}