// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:ssh|https):\/\/(?:git@)?bitbucket\.org\/([^/]*)\/([^/.]*)").unwrap();
let string = "https://bitbucket.org/test/test-x.git
ssh://git@bitbucket.org/test/test-x";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}