re = /(?i)(\d*\.?\d+)\s*(?:tab|cap|grag|past|sob|comp)/m
str = ' PRODUCTS
0 PULSAR AT 20 MG ORAL 30 TAB RECUB
1 LIPITOR 40 MG 1+1 ORAL 15 TAB
2 LOFTYL 150 MG ORAL 30 TAB
3 SOMAZINA 500 MG ORAL 10 COMP RECUB
4 LOFTYL 30 TAB 150 MG ORAL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end