package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\+[0-9]{2} (\(0\))?[0-9]{3} [0-9]{2} [0-9]{5}`)
var str = `+49 (0)551 39 21490
+49 551 39 21490`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}