// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\+[0-9]{2} (\(0\))?[0-9]{3} [0-9]{2} [0-9]{5}").unwrap();
let string = "+49 (0)551 39 21490
+49 551 39 21490";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}