$re = '/\+[0-9]{2} (\(0\))?[0-9]{3} [0-9]{2} [0-9]{5}/m';
$str = '+49 (0)551 39 21490
+49 551 39 21490';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);